Get in touch
Back
Maintenance

Iridium Switch Upgrade (Part 2/2)

Completed 18 Aug at 06:30pm BST.

Core Tracking Platform
Completed

Maintenance completed

Posted 18 Aug at 06:30pm BST.
Started

Services will be unavailable for no more than 15 minutes. During this time frame, Iridium will move the physical connections supporting circuit switched voice and data services over to the new switch.

All customers with Circuit Switched Voice and Data based services or products will be impacted. This includes safety services, enhanced services, and over the top services based on or dependent on Iridium’s Circuit Switched Voice and Data services:

Telephony Voice
SMS
Dial up data
Direct Internet
Access Point
Iridium GO!
RUDICS
Pre-paid (voice and data)
Captain Calling
Crew Calling
2 stage dialing
Local Number Dialing
FAX
OpenPort® Voice
Certus Voice
Air Traffic Safety
GMDSS

Posted 18 Aug at 05:45pm BST.